Jumat, 21 Juni 2013

Laporan Praktikum Jaringan Komputer 10


Nama                   : Hudda Affandi
Kelas                    : 2A
NIM                      : 12 615 009

Activity 6.4.1:
Basic Inter-VLAN Routing

Tujuan Praktikum
1.      Mahasiswa dapat mengetahui bagaimana caranya menggunakan Vlan pada setiap switch.
2.      Mahasiswa dapat mengerti cara konfigurasi pada setiap witch.
3.      Mahasiswa dapat mengetahui ternyata Vlan dapat disimpan di router sebagai server

Pendahuluan
Satu VLAN adalah satu broadcast domain, sehingga satu buah komputer di sebuah VLAN tidak dapat terkoneksi dengan komputer yang berbeda VLAN. Agar komputer yang berbeda VLAN dapat terkoneksi maka dibutuhkan perangkat layer 3 yaitu router. Persyaratan router yang dapat dipakai untuk routing VLAN adalah router tersebut harus bisa dibuat trunking ke switch. Oleh karena itu, router-nya harus tersedia interface fastethernet, selain itu IOS untuk router tersebut juga harus mendukung trunking. Cirinya adalah interface-nya bisa dibuat subinterface, dan mendukung enkapsulasi ISL serta DOT1Q. Inter-VLAN routing adalah proses mem-forward traffic network dari satu VLAN ke VLAN lain menggunakan router. VLAN diasosiasikan dengan ip subnet yang unik pada network. Konfigurasi subnet akan memfasilitasi proses routing pada lingkungan beberapa VLAN. Ketika kita menggunakan router untuk memfasilitasi inter-VLAN routing, interface pada router dapat dihubungkan dengan VLAN yang berbeda. Setiap device pada VLAN tersebut mengirimkan traffic melalui router untuk mencapai VLAN lain.

Secara tradisional LAN routing menggunakan router dengan beberapa interface physical. Setiap interface harus dihubungkan dengan network yang berbeda dan dikonfigurasikan dengan subnet yang berbeda. Dalam network tradisional yang menggunakan beberapa VLAN, untuk mensegmentasi network traffic menjadi broadcast domain logical, routing ditunjukkan dengan menghubungkan interface physical router yang berbeda ke port  physical switch yang berbeda pula. Port switch terhubung dengan  router dalam mode  interface port. Setiap router interface kemudian dapat menerima traffic dari VLAN yang telah diasosiasikan dengan switch interface yang terhubung, dan traffic dapat di routing ke VLAN lain yang terhubung dengan interface lain. 

Inter-VLAN routing secara tradisional mengharuskan beberapa interface physical  pada kedua router dan switch. Bagaimanapun juga, tidak semua konfigurasi inter-VLAN routing mengharuskan beberapa physical interface. Beberapa router software memperbolehkan konfigurasi router sebagai link trunk. Hal ini membuka kemungkinan terjadinya inter-VLAN routing. Router on a stick adalah salah satu jenis konfigurasi  router yang mana sebuah  interface physical me-routing traffic antara beberapa VLAN pada network. Router interface dikonfigurasikan untuk beroperasi  sebagai link trunk dan terhubung dengan sebuah port switch dalam mode trunk. Router menunjukkan inter-VLAN routing dengan menerima traffic VLAN yang telah di tag pada interface trunk dari switch dan secara internal me-routing antar VLAN menggunakan sub-interface. Kemudian router akan mem-forward traffic VLAN yang di tag menuju VLAN tujuan pada interface physical yang sama. Sub-interface adalah beberapa interface virtual yang diasosiasikan dengan interface physical. Sub-interface ini dikonfigurasikan  dengan software pada router  yang secara independent dikonfigurasikan  dengan ip address dan VLAN untuk beroperasi pada VLAN tertentu. Sub-interface dikonfigurasikan untuk beberapa subnet yang berbeda namun berhubungan dengan VLAN lain yang memfasilitasi routing secara logical sebelum  frame data di tag VLAN dan dikirimkan ke physical interface.


Langkah Praktikum
Activity 6.4.1:
Basic Inter-VLAN Routing

Gambar 10.1 Tabel Addressing
Gambar 10.2 Tabel Port Assigment
Gambar 10.3 Tabel Konfigurasi Sub-Interface
Topology Diagram
Gambar 10.4

Mengkonfigurasi dasar switch
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname S1
S1(config)#no ip domain lookup
S1(config)#enab secret class
S1(config)#ip default-gateway 172.17.99.1
S1(config)#line con 0
S1(config-line)#pass cisco
S1(config-line)#login
S1(config-line)#line vty 0 15
S1(config-line)#pass cisco
S1(config-line)#login
S1(config-line)#end
S1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
S1#
Untuk Switch yang lain juga kita konfigurasi seperti di atas, dengan nama switch masing-masing S2 dan S3
Mengkonfigurasi interface ethernet pada PC dengan IP Address yang ada dalam tabel IP Address
Gambar 10.5 Konfigurasi PC
Konfigurasi PC yang lain sama seperti konfigurasi di atas dengan IP yang sesuai

Mengkonfigurasi VTP pada switch
Mengaktifkan port pengguna pada S2 dalam mode akses
S2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
S2(config)#int fa0/6
S2(config-if)#switchport mode access
S2(config-if)#no shut
S2(config-if)#int fa0/11
S2(config-if)#switchport mode access
S2(config-if)#no shut
S2(config-if)#int fa0/18
S2(config-if)#switchport mode access
S2(config-if)#no shut
S2(config-if)#exit
S2(config)#

Mengkonfigurasi VTP pada switch
Gambar 10.6 Tabel VTP
S1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
S1(config)#vtp mode server
Device mode already VTP SERVER.
S1(config)#vtp domain Lab6
Domain name already set to Lab6.
S1(config)#vtp password cisco
Password already set to cisco
S1(config)#exit
S1#

Untuk S2 dan S3, kita sesuaikan dengan tabel VTP
Mengkonfigurasi port trunk dan menandakan VLAN native untuk trunk
S1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
S1(config)#int fa0/1
S1(config-if)#switchport mode trunk
S1(config-if)#switchport trunk native vlan 99
S1(config-if)#no shut
S1(config-if)#exit
S1(config)#
Untuk S2 dan S3 juga kita konfig seperti di atas
Mengkonfigurasi server VTP dengan VLAN
Gambar 10.7 Tabel Nama VLAN
S1(config)#vlan 99
S1(config-vlan)#name management
S1(config-vlan)#exit
S1(config)#vlan 10
S1(config-vlan)#name faculty-staff
S1(config-vlan)#exit
S1(config)#vlan 20
S1(config-vlan)#name students
S1(config-vlan)#exit
S1(config)#vlan 30
S1(config-vlan)#name guest
S1(config-vlan)#exit
S1(config)#

Memeriksa bahwa VLAN yang dibuat pada S1 dapat didistribusikan ke S2 dan S3
S2#show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/5, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/12, Fa0/13, Fa0/14
                                                Fa0/15, Fa0/16, Fa0/17, Fa0/19
                                                Fa0/20, Fa0/21, Fa0/22, Fa0/23
                                                Fa0/24, Gig1/1, Gig1/2
10   faculty-staff                    active    Fa0/11
20   students                         active    Fa0/18
30   guest                            active    Fa0/6
99   management                       active
1002 fddi-default                     active   
1003 token-ring-default               active   
1004 fddinet-default                  active   
1005 trnet-default                    active   
S2#

S3#show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24
                                                Gig1/1, Gig1/2
10   faculty-staff                    active   
20   students                         active   
30   guest                            active   
99   management                       active
1002 fddi-default                     active   
1003 token-ring-default               active   
1004 fddinet-default                  active   
1005 trnet-default                    active   
S3#

Mengkonfigurasi alamat interface management
Untuk S1
S1(config)#int vlan99
S1(config-if)#ip add 172.17.99.11 255.255.255.0
S1(config-if)#ex
S1(config)#

Untuk S2 Ip address adalah 172.17.99.12 255.255.255.0 dan S3 adalah 172.17.99.13 255.255.255.0
Menugaskan port Switch ke VLAN pada S2
S2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
S2(config)#int fa0/6
S2(config-if)#switchport access vlan 30
S2(config-if)#int fa0/11
S2(config-if)#switchport access vlan 10
S2(config-if)#int fa0/18
S2(config-if)#switchport access vlan 20
S2(config-if)#end
S2#
%SYS-5-CONFIG_I: Configured from console by console
S2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
S2#

Mengkonfigurasi router dan meremote server LAN
Mengkonfigurasi dasar router
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R1
R1(config)#no ip domain lookup
R1(config)#enab secret class
R1(config)#line con 0
R1(config-line)#pass cisco
R1(config-line)#login
R1(config-line)#line vty 0 4
R1(config-line)#pass cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#

Mengkonfigurasi interface trunking pada R1
R1#conf t
R1(config)#interface fastEthernet 0/0
R1(config-if)#no shutdown
R1(config-if)#int fa0/0.1
R1(config-subif)#encapsulation dot1Q 1
R1(config-subif)#ip add 172.17.1.1 255.255.255.0
R1(config-subif)#int fa0/0.10
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip add 172.17.10.1 255.255.255.0
R1(config-subif)#int fa0/0.20
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip add 172.17.20.1 255.255.255.0
R1(config-subif)#int fa0/0.30
R1(config-subif)#encapsulation dot1Q 30
R1(config-subif)#ip add 172.17.30.1 255.255.255.0
R1(config-subif)#int fa0/0.99
R1(config-subif)#encapsulation dot1Q 99 native
R1(config-subif)#ip add 172.17.99.1 255.255.255.0
R1(config-subif)#exit
R1(config)#

Mengkonfigurasi interface server LAN pada R1
R1#conf t
R1(config)#int fa0/1
R1(config-if)#ip add 172.17.50.1 255.255.255.0
R1(config-if)#description server interface
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#

Memeriksa routing inter-VLAN
R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.17.0.0/24 is subnetted, 6 subnets
C       172.17.1.0 is directly connected, FastEthernet0/0.1
C       172.17.10.0 is directly connected, FastEthernet0/0.10
C       172.17.20.0 is directly connected, FastEthernet0/0.20
C       172.17.30.0 is directly connected, FastEthernet0/0.30
C       172.17.50.0 is directly connected, FastEthernet0/1
C       172.17.99.0 is directly connected, FastEthernet0/0.99
R1#
Hasil Praktikum
Setelah semua langkah-langkah praktikum, kita lihat presentasi keberhasilan. Apabila sudah 100%, maka kita telah selesai. Selain mengecek presentasi keberahasilan kita harus mengecek apakah semua item sudah terhubung dalam satu jaringan.
Untuk memastikan bahwa topology yang saya kerjakan sudah dalam satu jaringa di lakukan ping antara PC ke Server :
Gambar 10.8 Ping PC1 ke Server
Gambar 10.9 Presentasi Keberhasilan Praktek