Jumat, 21 Juni 2013

Laporan Praktikum Jaringan Komputer 9


Nama                   : Hudda Affandi
Kelas                    : 2A
NIM                      : 12 615 009

Activity 4.4.1:
Basic VTP Configuration

Tujuan Praktikum
1.       Mahasiswa dapat mengetahui bagaimana caranya menggunakan Vlan pada setiap switch.
2.       Mahasiswa dapat mengerti cara konfigurasi pada setiap witch.

Pendahuluan
VTP adalah suatu metoda dalam hubungan jaringan LAN dengan ethernet untuk menyambungkan komunikasi dengan menggunakan informasi VLAN, khususnya ke VLAN. VLAN Trunking Protocol (VTP) merupakan fitur Layer 2 yang terdapat pada jajaran
 switch Cisco Catalyst, yang sangat berguna terutama dalam lingkungan switch skala besar
yang meliputi beberapa Virtual Local Area Network (VLAN).
 Di dalam artikel VLAN pada beberapa edisi sebelumnya, Anda telah melihat konsep VLAN dan juga VLAN tagging protocol seperti ISL. Jika Anda ingat kembali, tujuan mengonfigurasi VLAN tagging adalah agar traffic dari beberapa VLAN dapat melewati trunk link yang digunakan untuk menghubungkan antar-switch. Meskipun hal ini merupakan hal yang baik dalam lingkungan yang besar, VLAN tagging tidak melakukan apa-apa untuk mempermudah pengonfigurasian VLAN pada beberapa switch. Di sinilah VTP mengambil bagian.
 VLAN merupakan suatu broadcast domain, sekumpulan port atau user yang kita kelompokkan. VLAN dapat mencakup beberapa switch, hal ini dapat dilakukan dengan mengonfigurasi VLAN pada bebarapa switch dan kemudian menghubungkan switch tersebut, dengan satu pasang port per VLAN.
 Kelemahan cara ini adalah banyaknya port switch yang menghubungkan switch tersebut. Cara ini juga lebih manual, membutuhkan lebih banyak waktu, dan sulit untuk dikelola. Oleh karena itu, muncullah VLAN trunking yang bertujuan untuk menghubungkan switch dengan interlink (uplink) kecepatan tinggi, dan beberapa VLAN dapat berbagi satu kabel.


 Trunk link tidak dibuat untuk satu VLAN tertentu. Satu, beberapa, atau semua VLAN aktif dapat dilewati antar-switch dengan mengguunakan satu trunk link. Adalah mungkin untuk menghubungkan dua switch dengan link fisik terpisah untuk setiap VLAN. Namun dengan semakin banyaknya VLAN yang dibuat, maka jumlah link dapat bertambah dengan cepat. Cara yang lebih efisien adalah dengan menggunakan trunking. Untuk membedakan kepemilikan traffic pada trunk link, switch harus mempunyai metode untuk mengidentifikasi frame setiap LAN.






Langkah Praktikum
Activity 4.4.1:
Basic VTP Configuration

 
Gambar 1.9 Tabel Addressing
Gambar 2.9 Tabel Port Assigments(S2 dan S3)




Topology Diagram
Gambar 3.9
Mengkonfigurasi dasar Switch
Switch>enable
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname  S1
S1(config)#enab secret class
S1(config)#no ip domain lookup
S1(config)#line con 0
S1(config-line)#pass cisco
S1(config-line)#login
S1(config-line)#exit
S1(config)#line vty 0 15
S1(config-line)#pass cisco
S1(config-line)#login
S1(config-line)#exit
S1(config)#end
S1#
%SYS-5-CONFIG_I: Configured from console by console

Selain emngkonfigurasi S1, kita juga harus mengkonfigurasi switch yang lain, masing-masing diberi nama S2 dan S3
Mengkonfigurasi PC 
Gambar 4 Konfigurasi IP PC

Kita juga harus memasukkan IP Address Pcyang lain dengan IP Address yang sesuai dengan tabel addressing

Mengkonfigurasi VTP dan keamanan switch
Mengkonfigurasi port pengguna dalam mode access pada S2 dan S3
S2(config)#int fa0/6
S2(config-if)#switchport mode access
S2(config-if)#no shut

S2(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/6, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/6, changed state to up

S2(config-if)#int fa0/11
S2(config-if)#switchport mode access
S2(config-if)#no shut

S2(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/11, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to up

S2(config-if)#int fa0/18
S2(config-if)#switchport mode access
S2(config-if)#no shut

S2(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/18, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/18, changed state to up

Untuk S3 juga kita konfigurasi seperti konfigurasi padaS2
Memeriksa VTP pada switch
S1#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 255
Number of existing VLANs        : 5
VTP Operating Mode              : Server
VTP Domain Name                 :
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x7D 0x5A 0xA6 0x0E 0x9A 0x72 0xA0 0x3A
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Local updater ID is 0.0.0.0 (no valid interface found)
S1#
Untuk S2 dan S3, kita juga dapat memberikan perintah yang sama
Mengkonfigurasi mode operasi, domain name dan password VTP pada switch
S1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
S1(config)#vtp mode server
Device mode already VTP SERVER.
S1(config)#vtp domain Lab4
Changing VTP domain name from NULL to Lab4
S1(config)#vtp password cisco
Setting device VLAN database password to cisco
S1(config)#exit
S1#
%SYS-5-CONFIG_I: Configured from console by console
Untuk S2 kita atur dalam mode client dan S3 dalam mode transparent
Mengkonfigurasi trunking dan VLAN native pada switch
Pada S1
S1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
S1(config)#int fa0/1
S1(config-if)#switchport mode trunk
S1(config-if)#switchport trunk native vlan 99
S1(config-if)#no shut
           
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to down
S1(config-if)#int fa0/2
S1(config-if)#switchport mode trunk
S1(config-if)#switchport trunk native vlan 99
S1(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/2, changed state to down
S1(config-if)#exit
S1(config)#

Pada S2
S2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
S2(config)#int fa0/1
S2(config-if)#switchport mode trunk
S2(config-if)#switchport trunk native vlan 99
S2(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

S2(config-if)#exit
S2(config)#



Pada S3
S3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
S3(config)#int fa0/2
S3(config-if)#switchport mode trunk
S3(config-if)#switchport trunk native vlan 99
S3(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/2, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up

S3(config-if)#exit
S3(config)#

Mengkonfigurasi port keamanan pada S2 dan S3
S2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
S2(config)#int fa0/6
S2(config-if)#switchport port-security
S2(config-if)#switchport port-security max 1
S2(config-if)#switchport port-security mac-address sticky
S2(config-if)#int fa0/11
S2(config-if)#switchport port-security
S2(config-if)#switchport port-security max 1
S2(config-if)#switchport port-security mac-address sticky
S2(config-if)#int fa0/18
S2(config-if)#switchport port-security
S2(config-if)#switchport port-security max 1
S2(config-if)#switchport port-security mac-address sticky
S2(config-if)#exit
S2(config)#

Untuk S3 kita juga konfigurasi seperti konfigurasi pada S2
Mengkonfigurasi VLAN pada server VTP
S1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
S1(config)#vlan 99
S1(config-vlan)#name management
S1(config-vlan)#exit
S1(config)#vlan 10
S1(config-vlan)#name faculty/staff
S1(config-vlan)#exit
S1(config)#vlan 20
S1(config-vlan)#name students
S1(config-vlan)#exit
S1(config)#vlan 30
S1(config-vlan)#name guest
S1(config-vlan)#exit
S1(config)#

Memeriksa bahwa VLAN telah dibuat pada S1 dapat didistribusi ke S2 dan S3
S2#show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                Fa0/22, Fa0/23, Fa0/24, Gig1/1
                                                Gig1/2
10   faculty/staff                    active   
20   students                         active   
30   guest                              active   
99   management                       active   
1002 fddi-default                     active   
1003 token-ring-default               active   
1004 fddinet-default                  active   
1005 trnet-default                    active   
S2#

S3#show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/3, Fa0/4, Fa0/5
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                Fa0/22, Fa0/23, Fa0/24, Gig1/1
                                                Gig1/2
1002 fddi-default                     active   
1003 token-ring-default               active   
1004 fddinet-default                  active   
1005 trnet-default                    active   
S3#

Membuat VLAN baru pada S2 dan S3
Pada S2
S2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
S2(config)#vlan 88
VTP VLAN configuration not allowed when device is in CLIENT mode.
S2(config)#

Pada S3
S3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
S3(config)#vlan 88
S3(config-vlan)#name test
S3(config-vlan)#exit
S3(config)#no vlan 88
S3(config)#

Mengkonfigurasi VLAn dengan manual
S3(config)#vlan 99
S3(config-vlan)#name management
S3(config-vlan)#exit
S3(config)#vlan 10
S3(config-vlan)#name faculty/staff
S3(config-vlan)#exit
S3(config)#vlan 20
S3(config-vlan)#name students
S3(config-vlan)#exit
S3(config)#vlan 30
S3(config-vlan)#name guest
S3(config-vlan)#exit
S3(config)#

Mengkonfigurasi alamat interface manajemen pada switch
S1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
S1(config)#int vlan 99

%LINK-5-CHANGED: Interface Vlan99, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan99, changed state to up

S1(config-if)#ip add 172.17.99.11 255.255.255.0
S1(config-if)#no shut
S1(config-if)#exit
S1(config)#

Untuk S2(172.17.99.12 255.255.255.0 ) dan S3(172.17.99.13 255.255.255.0) juga dikonfigurasi seperti konfigurasi pada S1 namun IP Address yang disesuaikan.

Menugaskan port switch ke VLAN
S3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
S3(config)#int fa0/6
S3(config-if)#switchport access vlan 30
S3(config-if)#int fa0/11
S3(config-if)#switchport access vlan 10
S3(config-if)#int fa0/18
S3(config-if)#switchport access vlan 20
S3(config-if)#end
S3#
%SYS-5-CONFIG_I: Configured from console by console
S3#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
S3#

Untuk S2 juga kita konfigurasi seperti konfigurasi pada S3
Hasil Praktikum
Setelah semua langkah-langkah praktikum, kita lihat presentasi keberhasilan. Apabila sudah 100%, maka kita telah selesai. Selain mengecek presentasi keberahasilan kita harus mengecek apakah semua item sudah terhubung dalam satu jaringan
Untuk membuktikan apakah Vlan sudah berhasil kita harus mengeping antar Vlan dengan nama yang sama contohnya PC1 dengan PC2 :
Gambar 6 ping PC1 ke PC 2
Gambar 6 Presentasi Hasil Praktikum

Gambar 7 Hasil Praktikum

Tidak ada komentar:

Poskan Komentar